Kel-Tec Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
OK just got back from a short session at the range tonight and am not a happy camper. I shot my new Springfield Micro Compact and it was giving me occasional FTEs and FTFs, and then my (also practically new) P3AT which gave me a string of FTEs.

I got through the first mag in the P3AT OK but toward the end of the second mag and thoughout the third mag it FTEd practically every single time. The extractor was not getting a grip and leaving the spent case in the chamber. The next round would be picked up by the bolt and nosed into the spent case. After that I fired three more mags with no problems. I had cleaned and lubed it since it was last shot too. I wonder if maybe someting had gotten the extractor bound up or stuck out of place? Maybe some crap got in the chamber and caused the cases to bind. All I know is I'm not feeling so great about my back up gun now :( BTW this gun has only had 50 rounds through it prior to this. The ammo is Lancer, the local range plinking ammo that is actually reloads but of good quality, I've put thousands through my Glock and Witness with good results.

Any ideas what might have happened?
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #2 ·
OK guess I should have searched first. I found a previous thread about new extractors, and although my gun is new (H8Vxx) it still has the old style extractor, at least according to this picture: http://www.1bad69.com/keltec/extractor.htm

Is KT shipping the "new" extractors pictured here or is this a mod I have to do myself?

Also, I WILL be poishing the chamber ASAP.

Thanks.
 

·
Banned
Joined
·
5,800 Posts
If you've got the old extractor, give KT a call and they'll send you the newest one.
Also, watch out for limpwristing! Happens to everyone now and then.
Flyer
 

·
Registered
Joined
·
2,654 Posts
p3at

snafu, prior to firing my p3at i polished the chamber with 600 grit wet or dry emery cloth in the direction of operation. i also polish with a silicone impregnated cloth after i clean it. although i was never hit in the face with a fired case, a couple skimmed my head. i then did flyer's chamber hood mod and have not experienced any more skimmers. i also polish ALL my ammo with the silicone cloth when i get it home. i now have 147 rnds. thru mine without a mishap. 50 rnds. blazer and 97 rnds. win valu pak which i carry as my standard load. i use pressurized auto starter fluid to blow out the gun, especially the extractor. then just a smidgen of clp to ensure smooth operation. i've polished the ramp to a mirror finish and did the same to the top and slide rails then a LIGHT coat of militec grease, a drop of clp to the trigger, hammer and bar and voila! i'm in love again. stick with it. the p3at's worth it. :D
 
G

·
I had the same problem with mine and after attempting to replace the extractor and spring, I noticed that the new extractor spring that they sent me was approximately 1/4 longer than the old one. I sent the slide back to KT and went ahead and exchanged the old slide for a HC one. When I shot the P3AT with the new slide I had ZERO malfunctions. Not sure what the difference was between the two but the HC one is alot better.
 

·
Registered
Joined
·
2 Posts
my p3 was doing the same thing so i drove over there after work 5 miles from were i work and marty fixed me up i just got back from shoting it 80 rounds and it was fine .and i got the hd finish.next week i will put some more rounds in it .i shot target wad gutters and fmj .
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top