Kel-Tec Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey. I just found this forum and have a problem. I have been carrying my Kel-Tec P-11 9mm for around 10 months or so and am frustated that hollow points jam on the feed ramp when I try to chamber a round.

I pull the slide all the way back and let it fly forward but most of the time the round gets stuck half way up the ramp to the chamber.

Does anyone have any suggestions on what I should do?

Thanks!
-Todd In Texas
 

· Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
WOW... Thanks for all the usefull help from everyone. Nice to see you here too Flyer.

MurrayNevada/Midiman I have a Dremel that I'll try to polish up that ramp... and I'm looking to buy some of those Cor-Bon Pow'R'Balls as well.

flyer The Kel-Tec came with one factory with one magazine but I bought two spare ones. I'll check the mag lips on top and adjust them and see if that helps.

Keys
1) I was going to get a polishing kit for my Dremel to polish that ramp.
2) The ammo that was jamming was Federal Premium Hydra-Shok JHP 135 grains. 9mm Luger of course.
3) I clean it regularly.
4) The Kel-Tec was purchased new by me last April (8 mos) and has only 600-800 rounds through it so far.
5) Blued slide.

Lastly, I have never had a misfire but in addition to the failure to feed hollow points, I have had a couple extraction failures where the spent cartridge is left inside the chamber. D'oh!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top