Kel-Tec Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,273 Posts
Discussion Starter · #1 ·
I have a Llama model III 380 (small 1911 clone) imported by Stoeger Industries. I bought it last year from a cop, but it had no mag. I found one at a GS recently. The gun shoots really well but ALWAYS FTF on the last round only. The last round always goes in about half-way and jams. I can pull back the slide and push it in with a finger. Is the problem likely to be the mag spring? I checked Wolf and they don't carry one for it. It takes a slightly different mag than the current models and they're a little hard to find. Any ideas on what's causing the FTF, and where to find new mag springs and/or mags?
 

·
Banned
Joined
·
5,800 Posts
The little Llamas are great little guns.
Yep, it does sound like a mag spring problem.
Kinda funny... my model was made in the early 1940s and still works fine!
You can try VERY CAREFULLY bending the top loop of the spring up, right in the center of the loop where it's not subject to tension.
This will cause a little extra tension on the last round, and also should cause that round to ride a bit higher in the mag.
Worth a try, anyhow!
Just be sure not to stretch the spring, or bend it in any other areas.
Flyer
 

·
Registered
Joined
·
2,273 Posts
Discussion Starter · #3 ·
Oops... I did stretch it (mag spring) out a little a while back, but have since read that's a no no. It didn't seem to hurt it any as I shot it yesterday and it functioned exactly as before. I'll give your fix a try tomorrow and see what happens. I really like the gun, it's got a good feel to it and is quite accurate. It's just effectively a 6+1 instead of 7+1. The sights are a bit hard to see (for me). I wonder about changing them for something bigger and brighter but it might "look funny".
 

·
Banned
Joined
·
5,800 Posts
If all else fails, you can always get a current mag and use the spring from it... I can't see any reason why they wouldn't function just fine.
Flyer
 
1 - 4 of 4 Posts
Top