Kel-Tec Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Well, I have the sub 2K in the S&W 59 version. I fired about 350 or so rounds through it and had quite a few jams. Then it got to the point that I couldn't even load a round without it hanging up on the top of the chamber.

I finally got a new feed ramp (part 121) and changed it this weekend. It seems to have solved my problem. We will see next weekend.

Jeff

I'll post some pics of the worn vs a new one later.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Polymer.

It was easy to change. I haven't gotten to shoot it yet, but I can cycle 15 rounds through it and before I couldn't even do one.


Jeff
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Update

Went to the range this weekend and fired 300 rds through the sub 2000. I had no problems with
the stock 10 rd clip but the 15 rd clips were another story I had problems with the rounds
stacking almost side by side about an inch from the top. I actually had a round turn around
backwards. I noticed that the top right rear of the clip had witness marks from something striking
it. I am going to take a file to them later.

The ammo I used was a cheap steel cased ammo. It is a soft steel and the ejector is putting a good
nick in it so I'm not real worried about it damaging the gun. A guy next to me had set up a
chronograph and I fired a few rounds through it. The average was about 1230fps.

A guy on the other side of me (about 3 rows away) had a Bushmaster pistol (like an AR-15 w/o
stock and really short barrel. Good grief that thing is loud! I shot about 10 rounds through it and
all I could see was the sight picture and about a 20" diameter blast around the end. And I thought
my .357 was loud.....

Jeff
 
1 - 4 of 4 Posts
Top