Kel-Tec Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Well.....have put a few hundred through my hard chrome p3at now. This bout at the range, though, I noticed the assembly pin working its weasley way out. I was kinda bummed to see this, but I have read that this has been noted by others. Just curious what should I do? Fix it myself (http://www.1bad69.com/keltec/assemblypin.htm) or call KT?

By the way.....she still shot very well today with 0 FTFs or FTEs.
 

·
Registered
Joined
·
145 Posts
Do both. Call them and explain what happened & they'll send you a new one free. Do the yzguy fix on the one you have now and if it doesn't work or you mess it up, you'll have another one on the way.
 

·
Banned
Joined
·
5,800 Posts
Check inside the aluminum frame where the pin goes... make sure the holes aren't elongated.
If the pin only came partly out I'm sure you don't have any damage just yet.
Flyer
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
new pin arrived......*sigh*

Well.....the new assembly pin arrived from Kel-Tec. I verified there was no frame damage & installed the new pin. Hit the range today & popped off ~ 150 rounds. Almost once a mag I had to push the assembly pin back in as it was still sliding out (even though it was the "newer" one).

Kind of bummed about that.....going to call Kel-Tec but will probably do the fix on http://www.1bad69.com/keltec/assemblypin.htm

Still bums me out, though......

And I think I have frame damage from all this......
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top