Problems with new to me 1st Gen P32 - Page 2
Page 2 of 6 FirstFirst 1 2 3 4 ... LastLast
Results 11 to 20 of 52

Thread: Problems with new to me 1st Gen P32

  1. #11
    Junior KTranger
    Join Date
    Apr 2010
    Location
    Florida
    Posts
    23
    OK, that did it. The ejector/slide stop dropped and the slide went forward.

    Now how do I prevent that from happening again? Is that a defective slide stop or a burr on an edge or what?

    Thanks
    Furdog52

  2. #12
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    Now we need to figure out what it is. Do you have the slide assembly off the frame yet?



    Former Member May 2005 - April 2011

  3. #13
    Junior KTranger
    Join Date
    Apr 2010
    Location
    Florida
    Posts
    23
    Played with it some more and determined:

    It jams (slide locks back and will not release unless you depress the ejector with a screwdriver) everytime with the two 10 round mags I have. It jams about half the time with each of the 4 7 round factory mags I have. All mags are kel-tec factory mags, all have Mec-gar "made in italy" stamped on them.

    Are the mags fully interchangable between the current "2nd generation" guns and my 1st generation?

    Is there an adjustment I can make that will allow it to lock back when empty but not jam back? Don't really want to have to carry a screwdrive to be able to reload!

    Thanks
    Furdog52

  4. Remove Advertisements
    KeltecForum.com
    Advertisements
     

  5. #14
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    The mags are identical between generations. Did you take the slide off yet? Please do so and we can troubleshoot it properly.



    Former Member May 2005 - April 2011

  6. #15
    Junior KTranger
    Join Date
    Apr 2010
    Location
    Florida
    Posts
    23
    Slide off the frame. What next? (Student eagerly awaiting teacher's response)
    Furdog52

  7. #16
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    OK, here is what you want to do:

    Insert an empty mag into the grip, and check to see it is pushing the ejector/slide stop up like it is supposed to. Keep an eye on the ejector/slide stop as you push the mag in, and you should see it move up as the follower on the mag contacts it.

    Assuming it does go up, remove the mag. Does the ejector/slide stop go back down? Probably not...



    Former Member May 2005 - April 2011

  8. #17
    Junior KTranger
    Join Date
    Apr 2010
    Location
    Florida
    Posts
    23
    Wow! You are good! That is exactly what is going on. The mag pushes the ejector up, and it does not fall when the mag is removed.
    Furdog52

  9. #18
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    OK, the problem is with the ejector/slide stop, most likely with the grip. Hold on for a few minutes while I take a pic and post it for you so we can continue.



    Former Member May 2005 - April 2011

  10. #19
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    OK, now you need to see if the plastic grip is not tight against the aluminum frame. Look at the area in the red ellipse in my pic, and see if the grip has the same thin gap in this area as it does in other areas.





    Former Member May 2005 - April 2011

  11. #20
    KTrange Contributor
    Join Date
    May 2005
    Posts
    6,292
    Mine actually has a slight bulge in the pic I hadn't noticed, but still works fine.



    Former Member May 2005 - April 2011

Page 2 of 6 FirstFirst 1 2 3 4 ... LastLast

Sponsored links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. p-3at problems
    By srx in forum P-3AT
    Replies: 31
    Last Post: 05-05-2011, 06:31 PM
  2. 1st GEN.---NO more problems.
    By nomad1500 in forum P-3AT
    Replies: 6
    Last Post: 06-03-2006, 05:16 PM
  3. Do all .380's have problems?
    By ousooner in forum P-3AT
    Replies: 48
    Last Post: 02-05-2006, 04:17 PM
  4. FTF problems
    By Neil in forum P-32
    Replies: 14
    Last Post: 07-21-2005, 04:53 AM
  5. P-32 Problems
    By carolinaman in forum P-32
    Replies: 45
    Last Post: 02-09-2005, 02:53 AM

Search tags for this page

1st gen p32

,

gen 1 p32

,

kel tec p32 1st gen

,

kel tec p32 gen 1

,

kel tec p32 gen 1 problems

,

kel tec p32 problems

,

keltec p32 problems

,

p32 gen 1

,
p32 problems
,
release slide p32
Click on a term to search for related topics.